Introduction - Purpose of this document

This document is intended for users who wish to fabricate a photo mask through the NanoFab facility at the University of Alberta. It contains all the information necessary for you to familiarize yourself with the most common issues regarding mask fabrication.

Contents:

What is a Photo Mask? ..........................................................................................................................2
What is L-Edit? .......................................................................................................................................2
Design Flow................................................................................................................................................3
  Determining Your Process..................................................................................................................4
  Design Your Mask(s)..........................................................................................................................4
  Complete the Required Paperwork .................................................................................................4
  Submit Your Design for Fabrication .................................................................................................4
Introduction to L-Edit..........................................................................................................................................................5
  L-Edit CAD Concepts .......................................................................................................................5
  L-Edit Limitations and Nuances ......................................................................................................5
    Scaling Errors...................................................................................................................................5
    Limited Number of Cell Instances ..............................................................................................6
    Naming Errors..................................................................................................................................6
  Working with Curves ..........................................................................................................................6
    Changing the Manufacturing Grid...................................................................................................6
  Working with Cells............................................................................................................................7
    Creating a New Cell.........................................................................................................................8
    Instancing a Cell.............................................................................................................................8
    Changing Cell Parameters...............................................................................................................9
    Viewing the Design Hierarchy .......................................................................................................10
  Using Boolean / Grow Operations ....................................................................................................10
Final Layout Considerations ................................................................................................................12
  Alignment Windows..........................................................................................................................12
  Multi-Layer Alignment Marks..........................................................................................................13
  Edge Avoidance................................................................................................................................13
  Mask Centering................................................................................................................................14
  Adding Text.........................................................................................................................................15
  Adding Images.....................................................................................................................................15
  Write Time Considerations.............................................................................................................16
  Orientation..........................................................................................................................................16
  Short Circuits......................................................................................................................................16
  Exporting Your Design ......................................................................................................................17
Submitting Your Design ......................................................................................................................18
The File Conversion Flow ......................................................................................................................19
Photomask Fabrication Policy ...............................................................................................................20
Where to Get Help.................................................................................................................................21
What is a Photo Mask?

A photo mask is a piece of glass that you will use to transfer your design to a material layer that you wish to pattern for further processing. The physical properties of each mask fabricated at the NanoFab are:

- 5” x 5” soda lime glass
- 0.09” thick
- Chrome coated (approx 70nm thick)

**REMEMBER:** You will need 1 mask for each uniquely patterned material layer in your design

What is L-Edit?

L-Edit is the standard CAD tool supported and used within the NanoFab facility. L-Edit is one component in a suite of tools available from Tanner EDA. All of the tools of the Tanner EDA suite are available for your use in the NanoFab; however, due to our focus on fabrication, we only provide training and assistance with the physical layout component – L-Edit. For reference, the other available tools within the Tanner suite are:

- S-Edit – Schematic Capture
- LVS – Layout vs. Schematic
- T-Spice – Circuit Simulation
- W-Edit – Waveform Viewing & Analysis

L-Edit is not the only CAD program capable of creating designs compatible for fabrication in the NanoFab. You can use any program that is capable of producing a GDSII formatted output file; however, if you should choose to use some other CAD package, the NanoFab staff will be unable to provide you with any support or assist in troubleshooting any software issues that may arise. For this reason, we strongly recommend that you use L-Edit unless you already have experience with your favorite CAD program or have some other compelling reason not to use L-Edit.
Design Flow

Creating a mask is among the first steps to fabrication in the NanoFab facility; however, before you begin your mask design, you should consult our processing coordinator, Stephanie Bozic. This is to ensure you have a good idea of your process flow, and are aware of any considerations that you will have to take into account before starting your design.

Figure 2 - Mask Fabrication Flow
Determining Your Process

Before sitting down to begin your mask design, you should meet with a NanoFab staff member to discuss your project and determine the steps necessary to complete your objectives. You may have a very definitive idea of what you wish to do; however, it is important to determine how you will go about doing this within the constraints of the facility. Some considerations to be made at this point are:

- Substrates to be used
- Material layers to be used
- Number of layers to be used
- Pattern transfer options and limitations
- Type of photo resist to be used
- Geometry, dimensions and layout of your design
- Etch considerations
- Tools and processes required

**REMEMBER:** An ounce of prevention is worth a pound of cure

A thorough understanding at this stage of the steps required to complete your project can save you many headaches as you work your way through the fabrication process.

Design Your Mask(s)

Once you have determined your process flow, you can sit down to begin your mask design. At this stage, you will implement your design while adhering to your determined constraints and process flow.

Once you have completed your design, you should check it against your original plan to ensure that you have met all of your original requirements.

Complete the Required Paperwork

Before you can submit your design for fabrication, you must ensure that:

a) You are a registered user of the NanoFab facility. If you have not created a user account, you can visit our website [www.nanofab.ualberta.ca](http://www.nanofab.ualberta.ca) to complete this process.

b) You have been granted authorization to submit masks for fabrication. To gain authorization, be sure that your project supervisor has completed the Mask Authorization Form and submitted it to our facility. You will need 1 of these for each project you wish to submit masks for.

c) You have read and understand the Mask Fabrication Policies found on our website (and included in this document).

Submit Your Design for Fabrication

Once you have completed all of the above steps, you can submit your design for fabrication. All designs must be submitted online. Once your design has been successfully
submitted, we will take care of the rest and you will soon have a mask that you will use to carry on with your device fabrication.

**Introduction to L-Edit**

L-Edit is actually quite a powerful layout tool capable of full VLSI design implementation with DRC; however, in the NanoFab facility, we primarily make use of the most basic features. For a hands on training session of the most commonly used features and functions with respect to fabrication in the NanoFab, please contact Michael Hume [mikeh@ece.ualberta.ca].

**L-Edit CAD Concepts**

**Layers**  
In L-Edit, different layers are represented using different colors. Each layer (color) in your design will correspond to a unique physical mask. Therefore, if your design contains three layers (colors) you will need to fabricate three masks. Multi-layered designs require special considerations with regards to alignment. The default NanoFab design environment contains 10 drawing layers.

**Cells**  
In L-Edit, designs can be modularized using Cells. This is a highly effective and efficient method of creating your design. Cells can represent anything from a single feature to your complete design. They can be parameterised and reused throughout your design and are the building blocks of your hierarchy.

**Polygons**  
In the end, all of your features will be represented by polygons. It is important to keep this in mind as some shapes (ie. Curved features) will be approximated and may not be fabricated exactly as expected.

**Circles**  
Circles and other curved features require special attention during the design phase as they will ultimately be represented by polygons in your final output file. There are some tricks that can be used within L-Edit to maximize the resolution of the final approximated curves your mask will contain.

**Wires**  
Wires, also referred to as lines should be avoided when using L-Edit. The reason is that a line is defined by only two points within L-Edit. Wires and lines contain a special property called *WIDTH* which specifies the thickness of the line. In some cases, this property and it’s value are lost during the various conversion steps that take place along the road to fabrication. The result is a feature defined by only two points, which is not written by the pattern generator.

**L-Edit Limitations and Nuances**

As with any design tool, there are limitations that you may run into when working with them. Knowing these limitations can avoid headaches and unexpected results.

**Scaling Errors**

Instances that are scaled by a factor of 2000 or greater in L-Edit do not convert properly. They appear normal when imported back into L-Edit, but cannot be compiled into *.LIC files.
**Solution:** Instance the Cell into a new cell and scale it up to 2000 times the original size, then import the new Cell and scale it up to the final desired size.

**Limited Number of Cell Instances**

The maximum number of times you can instance a single cell within another is 4095. Exceeding this will not generate any errors in L-Edit; however, your design cannot be compiled into *.LIC files. Note that if you instance a Cell, and then turn it into an array (ex. 100x100), that counts as only 1 instance.

**Solution:** Instance a cell up to 4095 times in a single cell, then instance that cell into another as a single instance.

**Naming Errors**

The file conversion process spans a number of operating systems and using certain characters can cause problems along the way.

**Solution:** All structures in your design should adhere to the following naming conventions:
- Up to 32 characters in length
- Legal characters are: A-Z, a-z, 0-9, _, ?, $
- Do not start names with numbers

**Working with Curves**

The default L-Edit drawing shapes include some curved primitives. These are: Circle, Torus, and Pie Wedge. Often these are sufficient to complete your design; however, in some cases you may need to implement more advanced curved structures.

**Changing the Manufacturing Grid**

The manufacturing grid defines the resolution of polygons within L-Edit. By default, the grid is set to 0.5um. This provides a pretty good balance between resolution and file size; however, in some cases it does not provide sufficient resolution for small radial curves – recall that all curves will be approximated by polygons when your design is exported to a GDSII file.

You can increase the resolution of the approximated polygons by decreasing the manufacturing grid. To do this, select **Setup → Design**. This will open a dialogue box similar to the following:
From here you can change the Manufacturing Grid. You can go as low as 0.005um (5nm), increasing the resolution by a factor of 100. You can also check the box that says “Display curves using manufacturing grid”, this will cause all curved features to be shown as polygons, the way they will look when exported.

The trade off for this is a larger file size as all polygons will be rendered with this higher resolution. To help offset this, you can temporarily change the grid size when drawing circles (or other curved features) and then Draw → Convert → To Polygon those shapes, which will cause them to be converted to polygons immediately based on the current grid settings. Then change the grid back to the default 0.5um. and draw the remainder of your design.

Working with Cells

Cells are the building blocks of your design and can contain anything from a single feature to your entire mask. Cells allow you to reuse components of your design. In addition to this, they can be parameterized – i.e. scaled, arrayed, named and rotated to quickly build up your mask.
Creating a New Cell

All of the Cell functions can be found under the **Cell** menu in L-Edit, in addition, most of them also have keyboard shortcuts associated with them. To create a new Cell, select **Cell → New** or simply hit “N”. This opens a blank cell in which you can begin creating a new block, or instance an existing one.

Instancing a Cell

The power of Cells comes from the ability to instance them inside other Cells. To do this, select **Cell → Instance** or simply hit “I”. This will open the Cell instance dialogue box.

![Cell Instance Dialogue](image)

**Figure 4 - Cell Instance Dialogue**

From here you simply select the Cell you wish to instance. Note that there may be some Cells with a red X beside them. This indicates that you cannot place an instance of that Cell inside the current working Cell because it is either a) The cell you are working in or b) a cell further up in your hierarchy that contains the working cell. In either case, it would create a circular reference.
You can also instance cells from an external file, but be careful about this as you will have errors if you try to open your design on a computer that does not contain the external file.

**Changing Cell Parameters**

Once you have instanced a Cell, you can modify that instances’ parameters. Keep in mind that you can instance a single cell up to 4095 times in any other given cell, each one with difference parameters. To edit the instance parameters, select the instanced Cell and click `<CNTL> + E` or select **Edit → Edit Object(s)**. This will bring up the Object Editor dialogue.

![Figure 5 - Instance Editor](image)

From here, you can name the instance; change the rotation; move the object; scale it (note that is a factor); create an array; and change the delta (offset) of each arrayed member.
Viewing the Design Hierarchy

You can view your design hierarchy at any time by selecting View → Design Navigator.

This window shows you the layout of your design as well as the number of instances of a given cell within another. For example, we can see here that the torroid Cell has been instanced 13 times inside the cell_border_TORROID Cell.

Using Boolean / Grow Operations

The Boolean (or Grow) operations allow you to perform logical operations on multiple layers, and place the product on another layer. This is useful when you want to “punch out” shapes, or create more complex shapes.

REMEMBER: Boolean operations can only be performed on native shapes, and not on Cells.

Once you have drawn the shapes you wish to manipulate, select Draw → Boolean/Grow Operations or simply hit “B”. This will open the Boolean/Grow Operations dialogue:
In this case, we will perform an XOR operation on the two shapes pictures above. The result will be placed on Layer 3, and the inputs will be deleted after we are done. The result is as follows:
Final Layout Considerations

Once you have completed your design, you need to layout your mask to accommodate the substrate you plan to use. This can be a 4” wafer or perhaps you are using glass slides. Both scenarios are unique and require special attention to the final layout of your design.

It is recommended that at this point you create a new cell called “TopLevel” and do all of your final arrangement there. Using a guide/outline layer, you can draw shapes that correspond to your 5” x 5” mask as well as your substrate(s).

Now you can easily instance your design and array it to cover as much of your substrate as possible. You can also add final touches like your name, date, mask name, and possibly consider some of the following as well.

Alignment Windows

If you are printing a negative mask (non-inverted), your mask will be mainly chrome. In this case, you will likely want to create a few windows so you can ensure your substrate is centered under your mask during the lithography step. These windows should be at least 5cm x 3cm.

![Figure 9 - Alignment Windows](image-url)
Multi-Layer Alignment Marks

When working with multi-layered designs, some care must be taken to ensure that your layers will line up properly. For this, you will need to place some alignment marks on your masks. There are many types of alignment marks, one example is below:

![Alignment Marks](image)

Figure 10 - Alignment Marks

This configuration would work for a two layer design. Note that you can vary the size of the alignment marks to provide a course and fine adjustment.

Alignment marks should be placed near the edge of the substrate, along the centerline. They must be transferred to your substrate so you can align the next layer. They should also be at least 0.5 mm² and should have a 2mm opening around them so they can be easily found during your lithography step.

Edge Avoidance

You should avoid using the outer 2-4 mm around the edge of your substrate. Resist can build up at the very edge of your substrate, as well as uniformity falls off near the edge of the wafer. In addition, this leaves room for handling or clamping the wafer without damaging features.
**Mask Centering**

Masks are automatically centered by the pattern generator during the write process. This is useful as it allows you to design your mask without worrying too much about the origin, focusing your efforts on alignment with respect to each layer.

This can however cause problems if your final layers do not have the same center. The software can not differentiate between your design, and auxiliary features such as alignment windows or text labels.

Consider the following examples.

*Figure 11 - Auto Centering*
In the first example, the design is centered. In the second example with asymmetrical windows, the design ends up shifted as the windows are included in the design shifting the center. The final example adds offsetting windows (or a small balancing feature) to move the design area back to the center of the overall mask.

Keep in mind that each layer must have the same center if you want them to line up in the end. Small offsets can be accommodated for by the mask aligners; however, their range of movement is finite and limited.

**Adding Text**

If you want to add text to your mask, you must use the **Layout Text Generator**. This is found by selecting **Draw → Layout Generators → Layout Text Generator**. This function will convert an arbitrary text string into polygons and allow you to place them anywhere on your mask. Port labels will not show up on your mask.

**Adding Images**

You can add images or logos to your mask using the **Import Image** function. Select **Draw → Layout Generators → Import Image** and L-Edit will attempt to convert your image into polygons that can be printed on your mask.

![Figure 12 - Converted Image](image-url)
Write Time Considerations

The standard mask charge includes up to 120 minutes of write time. If your mask goes over this, you will be charged an additional per minute fee. The time it takes to write your mask will be a function of your feature size, density and overall coverage area of your design.

In some cases you can mitigate the write time by considering the following:

- Fill large unused areas of inverted masks so the laser can skip those areas
- Use small balancing features on non-inverted masks instead of complete borders
- Consider your orientation

Orientation

The *.LIC files are defined vertically. This means that if you have long features, they should be orientated vertically to minimize the necessary “stitching” that takes place between stripes. Also, because the laser writes stripes vertically as well, properly orientating your design can reduce the number of stripes, and thus reduce the write time.

In the case above, Figure 14 would take less time to write than figure 15, even though they both contain the same design, density and total area coverage.

Short Circuits

If your mask is non-inverted, be sure to consider the outer perimeter of your design. If you do not have any alignment windows or balancing features, it is possible to short out
the entire perimeter of your design as it will be cropped and centered when writing – causing everything on the perimeter to touch the remaining chrome.

Exporting Your Design

Once you have completed your design, you will need to export it to a *.GDS file. This is the file that you will submit for fabrication. The export process is straightforward. Select **File → Export Mask Data → GDSII**.

![GDSII Export Menu](image)

**Figure 15 - GDSII Export Menu**

In the file export menu:

1. Select the final output name and location
2. Check “Fracture polygons with more than”
   - This will ensure that no single polygon contains more than 199 vertices (a limitation of the DWL200)
3. Choose “Selected cell and its hierarchy”.  
   - This will ensure that only your top-level cell, and any cells instanced within it are exported. Any unused cells will not be exported.
4. Click Export

Review the log file and rectify or acknowledge and warnings or errors. Once you have your GDSII file, you should re-import it into L-Edit and verify your design.

**REMEMBER:** The NanoFab does NOT perform any design checking or previewing. The onus is on you to ensure your design is correct.
Submitting Your Design

The final step to fabricating your mask is to submit it for fabrication using our online submission system. Before you can do this, you must ensure that you have a valid NanoFab username and password, and that you (or your supervisor) have completed a Mask Authorization form. Without these pieces of paperwork in place, you will not be able to submit your mask.

You will submit your GDSII file. If you have a multi-layered design, you will use the same GDSII file for multiple submissions, changing the fabrication parameters as necessary for each layer. Be sure to check the Mask Fabrication Policy for the latest restrictions regarding mask submission.

During the submission process, you will be required to provide the following:

- **GDSII File** (10MB Max): If your file exceeds this size, you will have to make special arrangements and pay an additional fee.
- **Final Cell Name**: The name of the highest level Cell in your hierarchy – in our example TOPLEVEL.
- **GDSII Layer**: This number determines which layer will be fabricated. This information is found in the layer setup window in L-Edit.
- **Pitch**: This is used as a guideline by the NanoFab Staff when developing your mask. It should be the smallest feature/pitch in your design.
- **Exposure Mode**: Determines the polarity of your mask. Inverted (polygons = chrome) vs. Non-Inverted (polygons = glass).
- **Orientation**: RRCU – Design is NOT flipped on the Y-axis; RRCD – Design is flipped on the Y-axis. Think litho/backside patterning.

Once your design is submitted, you will be notified by email as your design makes its way through the queue. You can also check on the status online. When the status of your mask is DONE, your mask is ready for pick-up (or shipping).
The File Conversion Flow

As your design moves through the fabrication process, it will be converted between a number of different file formats. Below is a brief summary of the conversion process and a brief explanation of each of the steps. Many of these steps are performed by the Nanofab staff and are simply included here for informative purposes.

During the initial design phase, your file is stored as a *.TDB (tanner database file). This is the internal L-Edit file format. Once you have completed your design, you will export it to a *.GDS (GDSII) file for submission. You should re-import this file into L-Edit and ensure that all of your features were exported as expected. From there, your submitted file is complied into *.LIC (Stripe Files) that are used by the DWL200 to actually write your mask. This final conversion to *.LIC files is performed by the NanoFab Staff.
Photomask Fabrication Policy

Below is the NanoFab Photomask fabrication policy. The most current version can always be found on our website and in the case of discrepancies, the website will be taken as the authority.

- All photomask requests must be submitted online.
- 1 submission = 1 mask. Multi-layer designs require 1 submission per layer.
- Multi-layer submissions must use the same GDSII file
- Due to inherent differences in various CAD program outputs, mask results may vary
- Minimum feature size is 1um; however, features below 2um may show distortions
- Turn around times may vary due to staff resources and equipment availability
- Software support is provided on-site using L-Edit and the NanoFab design environment. The NanoFab is not responsible for the integrity or compatibility of designs produces off-site, or with other versions of L-Edit.
- Only the GDSII file format is accepted.
- The Maximum file size is 10MB. To date, the average file size is 1.07MB. There will be a 10% (of the total cost) per MB surcharge for files over 10MB.
- Your GDSII data files will be stored for 1yr from the date of submission.
- Masks with a problem status will be held in the queue for a maximum of 5 days, after which they will be deleted.
- If there is a problem with 1 layer of a multi-layer mask set, all layers must be resubmitted.
- All status updates are sent automatically via email. It is the user’s responsibility to ensure that the NanoFab has the correct email address on file. Users can manage their contact info online.
Where to Get Help

Administrative Assistance

Melissa Hawrelechko
780-492-0167
melissa.hawrelechko@ualberta.ca

If you need help with obtaining your NanoFab username and password, setting up a research group or completing the required paperwork associated with mask submission, please contact Melissa.

Process Flow Assistance

Stephanie Bozic
780-492-6724
sbozic@ualberta.ca

If you have any processing related questions, please contact Stephanie.

CAD Assistance

Michael Hume
780-492-1965
mikeh@ece.ualberta.ca

If you would like to arrange L-Edit training, or have any questions regarding the CAD aspect of mask design, please contact Michael.

Mask Printing and Developing

Les Schowalter
780-492-4829
les.schowalter@ualberta.ca

For questions or concerns regarding the Heidleberg pattern generator or any of the physical mask development steps, please contact Les.